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In M1 Exercise 1, we have just created a shapefile from the CSV file and we have applied symbology.
In this exercise, we will learn to:

Perform spatial query to create a subset data of facility for a particular block
Overlay a block boundary to clearly represent the limit of the block
Generate a map, printable on A3 Paper size in the JPEG file format

Generate areport on the available bedded hospitals per block

oCow>

The file is redistributable and can be shared with the
T yEm— block administrative agencies. This map will be useful
A to proposed aroad at block level or village level. The
| final output map will look something like below
consisting of North Arrow, Scale Bar and Legend.

Data Resources you will require:
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1. Open Project file: We are going to use
Exercise 1 (Facility Details for Citizen. qgz)
project file which is also available in the
resource file of the exercise directory.

Just Double click on the Facility Details for
Citizen. qgz from the repository

This project file will upload all the layers
along with the symbology style which we
have applied in exercise 1.
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2.Load Block Boundary: All states have
a block boundary at the state level in the
form of a single / mosaic layer. We are
going to use this layer and will filter the
data to get a single block boundary. The
same boundary can further be used to
select the facilities which are inside this
boundary.

a. Click on the ‘Open Data Source
Manager'.

b. Select ‘Vector’ Layer. In Source,
browse to the available Block
Boundary shape file (for this exercise
user can use the file available in the
Resource folder).

Please select ESRI Shape files (*.shp
*SHP) from the lower left drop down
menu.

c. Select Open > Add

Please notice that a new layer (Block
Boundary) has been added now in the
canvas.

Exit from the data source manager.
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3. Filtering Block Boundary

a. Right click on the ‘Block boundary’ layer.

b. Click on “Filter...”. A Query Builder will open.
c. In Fields list, double click on “Block Name”.

d. Click on the “=" operator, then double click on the Block Name
which is displayed in the Value list. To get all block name click on All.

e. Click Ok

OR After step 2 User can type expression and click ok.
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To see the Block boundary on canvas, user needs to
right click on the Block Boundary layer and click on
the “Zoom to Layer”. A Block boundary as shown in
the image below will be visible.
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4. Applying Simple symbology to Block Boundary Level
a. Right Click on the Block Boundary Layer in the Layer

panel.
b. Click on the Properties
c. Click on ‘Symbology’

d. Then Select “outline black” from the available symbols.

e. Click OK
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Notice the map visualization in the canvas will change
accordingly. The layer legend will also be changed.

Note: Symbology of all features should be based on GRISS’s
Standard symbol to standardize the map.
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5. Creating a Subset of the Facility Layer: Open the Attribute table by right clicking on the
‘FacilityDetailsForCitizen’ Layer and then selecting ‘Open Attribute Table’.
Examine the Attribute Table. In the attribute table, we don’t have any field which represents the block or
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district, so we are going to use the GIS tool “Select By Location” to select facilities which fall within the block

only.

Go to Main Menu > Click Vector > Research Tools> Select by Location...

Note: There are some other tools also that we can use to subset the layer. We will explore some of them in

our subsequent exercises.
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6. In the 'Select by location’ dialog box,

a. Select ‘FacilityDetailsForCitizen’ in the 'Select features
from’

b. Check’Intersect’ as the geometric predicate.

c. Set’Block_Boundary’in’'By comparing to the features
from’.

d. Keep Default value in ‘Modify current selection by'.

e. Click Run.

After the process is finished, user will
facilities from "FacilityDetailsForCitiz
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see some highlighted
en” layer, which falls

within the “Block_Boundary” polygon .
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In the Save Vector Layer as... dialog, TP, J—

7. User can save only highlighted

: e a. Select ESRI Shapefile as the format. GRAM SADAK YOJANA
igggjﬁfj)%;ar;?Sr;toilé:ﬁt(ilznegngPa;r;er S b. Save the output “Adimaly_Facilities.shp” to the resource directory.
Export > click on Save Features As.. c. ‘Save only selected features’ should be checked.

d. Keep ‘Add saved file to map’ checked to add file in the canvas >
OK

(2 Facility Details for Citizen_copy - QGIS — [m] X (2 Save Vector Layer as... X
Project Edit View Layer Settings Plugins Vector Raster Database Web Mesh HCMGIS Processing Help

DDERR OS2 RPD L RBEFS Nre-LEE- B 1 Format  JEsrr file v

- 2] :P i = ~ . b »
R@ViAZaWMm@ vy B Q ¥ vz Bl Yo e
[ 2 5 v Ul&h
‘ Layers =4 *( r
b annan CRS EPSG:4326 - WGS 84 v |&
cA®TE-FHED m@"&wu Eravikulam National Park = oevantils .
& [ Block Boundary v } Na >J°’ . =
~ i . e, . i
E” 42 Zoomto Layer Ma: ' lam -.n'km&m)‘ Bl il e
: 4 §9 Zoom to Selection 2080 hgé\ fty ESave only selected features 3
F= Bedded Hospital og oo i Ovverviow o o i} “.‘J§

Cold Storage Z w Select fields to export and their export options
ow Feature Count

Set Layer Scale Visibility...

OO SN

Sugar Mills

« B +

]

@ o

[ ¢~ Collection Centre or Pack Copy Layer - Name Type

1 [# Community Health Centn Rename Layer [ﬁnmlam . .

[ = Degree College G ounemet Chillithodu analla)soe & Habitation String
; | Duplicate Layer 2 v

£ & GRaM (Notied Re:m Lay:" gllocmos S M Facility C  String

B4 M High School - General

& M High School - Girls Move to Top M Facility S String

I @ Higher Secondary School % QOpen Attribute Table

i Is Part of Rurban Cluster? /' Toggle Editing K

B A m Filter... '!,f

[ # Mandi (Notified) Change Data Source...

|| Primary Health Centre Kam

M

=]

M =

Set CRS » ; S
Veterinary Hospital % @ = | Select Al Deselect All
Export L7 Save Features As...
Warehouse ’
g Styles » Save Selected Features As... m : ‘nammﬂmus’? ' ¥ Geometry v
Save as Layer Definition File...
v [F] ¥ Google Maps Propertls 1 ! ~ Tht 'F‘“d" Cardamom °
Save as QGIS Layer Style File... | Twp i e 5 o) & 5 saved file to map | Cancel Help
[Q Type to locate (ctri+k) | Toadl ordinat| 8546894,1130766 | cak| 1:240381 | @ lagnifie|100% 2] otator |on 2| I Render @EPSG 3857 @ L

[ ] 5




A new layer
“Adimaly_Facilities” is added
to the Layers panel with
features falling within the
“Block_Boundary” polygon
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8. Copy the Symbology: We will now use a copy and
paste method to symbolize each point according to the
“Facility S” value. Right Click on the Source Layer
(FacilityDetailsForCitizen)> Styles > Copy Style > click on
Symbology to copy the symbology.

PRADHAN MANTRI

Now we can simply paste the symbology to 2 sibAR youANA

(Adimaly Facilities) layer as shown in the image
below.

Note: Copy and Paste method only work when the
layers attribute fields and values are same.
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9. We can now remove the "FacilityDetailsForCitizen”
layer by right clicking on the layer and then clicking on
Remove Layer... to remove the current Layer.
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10. Export the map: ‘Print Layout’ can be used to create
maps.
Go to Project > New Print Layout.
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11. User will be prompted to enter a title
for the layout. user can leave it empty or
provide a name for future reference and
click Ok.

(2 Create print layout Title X

Enter a unique print layout title
(a title will be automatically generated if left empty)

Exe 2 Fadility Dtails for Citizen|

OK Cancel
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12. We will change the default A4 paper size to A3,

Right Click on the white portion on the paper > Page Properties..

Change the size A4 to A3 in the item property panel and notice change in the
paper size. Click on Zoom full button to display the full extent of the Layout.
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13. We now have to bring the QGIS Canvas data with symbology to the layout.

Select > Add Map
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After clicking on the Add Map, hold the left mouse button and drag a rectangle (From Upper left corner to Lower Right Corner
then release mouse button) where you want to insert the map.
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Notice the rectangle window
will be rendered with all the
layers from the main canvas.
This window may not be
covering the full extent of block
boundary.

Use Select/Move

item and Move Content options
to pan the map in the window
and center it in the composer.
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We can also click on Zoom
full button to display the full
extent of the Layout and
adjust the zoom level for the
manp.

Click on the’'ltem
Properties’ tab and

enter 175000 as

the Scale value.
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14. Now we are going to add some standard map elements like North Arrow, Legend and Scale Bar to the map.

Click Add Item > Add North Arrow
You can also choose from the standard tool bar.

Click on the layout where you want the North Arrow to appear.
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15. Click on the layout where you want the scalebar to appear. In the '[tem Properties’ tab > In PRADII.\‘I\' MANTRI
the Segments panel > change the 'Fixed width’ to 20 units and adjust the segments to your liking. GRAMSADAK YOIANA
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16. Click on Add Item > Add Label -to add title of the
map, you can increase the size of the font by clicking on

the font here we are using 15 size.
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17. To add legend, click on Add Item > Add Legend, then click on
the map and draw a box where the legend should be and adjust
the box.

In the ‘Item Property’ tab, Uncheck ‘Auto update’, select
‘Google map’ to remove from the legend.
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18. After putting all the elements, user can now export map as an Image, User will be prompted a WMS Layer message
PDF or SVG. For this Exercise, Click Layout > Export as Image to save > close this
map in Jpeg format.
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Facility Details for District: Idukki , Block: Adimaly

20 km

<

3 Block_Boundary
Adimaly_Facilities

BN

s ®RB L]

>

Agro Industry

Bedded Hospital

Cold Storage

Collection Centre or Pack House
Community Health Centre
Degree College

GRaM (Notified)

High School - General
High School - Girls
Higher Secondary School
Is Part of Rurban Cluster?
ITI

Mandi (Notified)

Primary Health Centre
Sugar Mills

Veterinary Hospital
Warehouse

PRADHAN MANTRI
GRAM SADAK YOJANA

This is the exported Jpeg image
of the block.



Bedded hospitals per block ’
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Next, we will look at filtering only the bedded hospitals per block.. This can be produced easily in excel if we
have the Block ID or Block Name against each facility. Unfortunately, block information is not available in
the facility shapefile.

However, using the ‘spatial join’, we can transfer block Id and Block Name from one layer (Block Boundary) to
another (FacilityDetailsForCitizen) based on their spatial relationship.
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2.In the Query Builder, type the following

expression to get all the records of the bedded

hospitals.

"Facility S" = 'Bedded Hospital'

Click OK.

3. Now we can do a spatial join using this layer. Go

to Processing > Toolbox.
Search and locate the Vector general > Join attribute
by location (summary) algorithm. Double-click to

launch it.
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{2 Query Builder

Set provider filter on FadiityDetailsForCitizen
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4. In the ’Join attribute by location (summary)’ dialog,
select Block_Boundary as the Input layer. The

FacilityDetailsForCitizen will be the Join layer. You can leave

the Geometry predicate to the default Intersects. Click

the ... button next to Fields to sumarize.

Q Join Attributes by Location (Summary)

Parameters Log

la
(- Block :43 e |5
Selected features only
Join layer
I . FadiityDetaisForCitizen [EPSG:4326] ~ I

Selected features only
Geometric predicate
O overlaps
[OJequals  [J cosses
[ touches
Fields to summarise (leave empty to use all fields) [optional]
0 elements selected
Summaries to calculate (leave empty to use all avaiable) [optional]
0 options selected
[[] Discard records which could not be joined
Joined layer

X

[[C'eatc temporary layer]

EA Open output file after running algorithm

Run as Batch Process...

Join attributes by
location
(summary)

This algorithm takes an input
vector layer and areates a new
vector layer that is an extended
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additional attributes in its
attribute table.

The additional attributes and
their values are taken from a
second vector layer. A spatial
criteria is applied to select the
values from the second layer
that are added to each feature
from the first layer in the
resulting one.

The algorithm calculates a
statistical summary for the
values from matching features in
the second layer (e.g. maximum
value, mean value, etc).

0% Cancel

5. Select Facility_S and
click OK
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(2 Multiple selection
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6. Similarly, click the ... button next to 'Summaries’ to
calculate.

Select count as the summary operator and click OK. 7.Browse the location to save the output and provide the

name and filetype (CSV)
Now we are ready to start the processing. Click Run.

Q Join Attributes by Location (Summary Q@ Multiple selection e ) :
Close the window after process completion.
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" FadiityDetailsForCitizen [EPSG:4326] e ™ ol | o0, with rganize ¥ ew folder = @
L — in its b
Selected features only O stt_ide\r E A Name Date modified ™
Geometric predicate B minofiky i s Quick access
. majority fr GIS Curriculum for PMGSY 01-07-2020 16:22
[ intersects [] overlaps Oaq A spatiz B Desktop * i
D contains D within D q3 lect the BGS 01-07-2020 15:5€
o+
W (e O iar pyer ‘ FA - ' Work from Home 30-06-2020 15:44
[ touches 8 — the 5| Documents * Education 22-06-2020 21:08
Fields to summarise (eave empty to use all fields) [optional] | | [] min_length N - =] Pictures 4 Work Exp 22-06-2020 18:3C
0 elements selected - e NRIDA * Habitation_Benifitted 21-06-2020 22:51
: F - alures in
Summaries to calculate (eave empty to use all available) [optional] the second layer (e.g. maximum BGS » Dlyaan 21-06-2020 19:57
T saiec D value, mean value, etc). " o e o
KADAMTALA Spatial Thought 17-06-2020 10:47
] Discard records which could not be joined -] 17 Az a2 Y
Joined layer Section1 Exercise2 Producing ¥ € >
Jicreate temporary layer] |E File name: | Bedded Hospital_Bllock v
[“] Open output file after running algorithm 7 :
Save as type: | CSV files (*.csv) v
0% Cancel [
, : , , ~ Hide Folders Save Cancel
Run as Batch Process... | Run Close || Hep




Notice now, in the main QGIS window, you will see a new Joined table (Bedded Hospital_Block) added ‘
to layer panel.

When you open the table, you will see a new column Facility S_count added to the input layer attribute
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(Block boundary). This contains the count of all bedded hospitals which are intersecting with that

___feature.
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Congratulations!

You have now completed
Module 3.



